Issue in Team Pro data synchronization

Incident Report for Polar

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 13:56 UTC

Investigating

We are currently investigating why some customers are experiencing issues in data synchronization. Sync seems to work, but data is not available in web service. We apologize the trouble caused and thank you for your patience!
Posted Oct 30, 2025 - 08:58 UTC
This incident affected: Polar Team Pro and Polar Team Pro mobile application.