Services recovering from maintenance

Incident Report for Polar

Resolved

This incident has been resolved.
Posted Apr 29, 2025 - 11:09 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 29, 2025 - 10:15 UTC

Monitoring

We have now performed the maintenance tasks and all services are back online. Services are still, however, recovering so you may experience for example slowness for a few hours. If you run into any issues, please try again a bit later.
Posted Apr 29, 2025 - 07:04 UTC
This incident affected: Polar Flow web service, Polar webstore, Polar Flow mobile application, Polar Beat mobile application, polar.com website, support.polar.com, account.polar.com, Polar Club mobile application, Polar Team Pro, Polar Team Pro mobile application, Polar GoFit web service, Polar GoFit mobile application, Polar API/3rd party sync, Data transfer to MyFitnessPal, Data transfer to Strava, Data transfer to TrainingPeaks, Data transfer to komoot, and Data transfer to Nike.