Slowness and sync problems caused by Daylight Saving Time

Incident Report for Polar

Resolved

This incident has been resolved.
Posted Oct 26, 2025 - 20:03 UTC

Identified

Our servers are always experiencing extra high loads on the day that Daylight Saving Time starts or ends. This may show as slowness or synchronization failing altogether. Please try again later. Thank you for understanding!
Posted Oct 26, 2025 - 06:14 UTC
This incident affected: Polar API/3rd party sync, Data transfer to MyFitnessPal, Data transfer to Strava, Data transfer to TrainingPeaks, and Data transfer to komoot.