support.polar.com partially down
Incident Report for Polar
Resolved
The Polar support material portal is back up again. Apologies for the inconvenience.
Posted May 04, 2021 - 08:32 UTC
Investigating
Unfortunately the Polar support material portal is experiencing slowness at the moment, and some pages may fail to load altogether. Apologies for the inconvenience the downtime may cause you.
Posted May 04, 2021 - 07:19 UTC
This incident affected: support.polar.com.